Deprecated: Assigning the return value of new by reference is deprecated in /home/worldofb/public_html/llvmruby/wordpress-llvmruby/wp-settings.php on line 468

Deprecated: Assigning the return value of new by reference is deprecated in /home/worldofb/public_html/llvmruby/wordpress-llvmruby/wp-settings.php on line 483

Deprecated: Assigning the return value of new by reference is deprecated in /home/worldofb/public_html/llvmruby/wordpress-llvmruby/wp-settings.php on line 490

Deprecated: Assigning the return value of new by reference is deprecated in /home/worldofb/public_html/llvmruby/wordpress-llvmruby/wp-settings.php on line 526

Deprecated: Assigning the return value of new by reference is deprecated in /home/worldofb/public_html/llvmruby/wordpress-llvmruby/wp-includes/cache.php on line 103

Deprecated: Assigning the return value of new by reference is deprecated in /home/worldofb/public_html/llvmruby/wordpress-llvmruby/wp-includes/query.php on line 21

Deprecated: Assigning the return value of new by reference is deprecated in /home/worldofb/public_html/llvmruby/wordpress-llvmruby/wp-includes/theme.php on line 618
many updates, new gem version at llvmruby.org

llvmruby.org

many updates, new gem version

3 comments

I’ve merged many good patches into the main llvmruby branch.  We are now officially using LLVM 2.4, compatible with Ruby 1.9 and more complete access to the LLVM API.

I recently became aware of a project by Marc-André Cournoyer using llvmruby to make a compiler for a little Ruby-ish language called Orange.

Miura Hideki has been making some great progress with his yarv2llvm project. He’s been compiling much more complex stuff and doing some really nice profiling work. I finally got to try it out for myself and it has a few issues running on 64-bit, so I plan on sending some fixes back his way.

Written by tom

December 24th, 2008 at 5:10 pm

Posted in Uncategorized

3 Responses to 'many updates, new gem version'

Subscribe to comments with RSS or TrackBack to 'many updates, new gem version'.

  1. Hi, I’m trying to install the newest gem. It seems the newest gem that GitHub built is version 0.0.2. Search for “tombagby-llvmruby” on this page: http://gems.github.com/list.html - It is also the version I get, when installing. On the other hand it should be 0.0.6 according to this file: http://github.com/tombagby/llvmruby/blob/e7fea89600ba497415baf61060671f5e981e784f/llvmruby.gemspec

    What happened?

    Bjarke Walling

    10 Feb 09 at 9:03 am

  2. I think what happened is that github didn’t build a gem for some reason the last time I touched the gemspec. I’ll go poke at it.

    tom

    10 Feb 09 at 9:42 am

  3. ? ?????????, ??, ??-?????, ?? ?? ?????. ? ??????. ????????? ??? ????????. ?????? ??? ? PM….

    ?? - ????????! ?????? ?????? ?? ?????????? ?????? I’ve merged many good patches into the main llvmruby branch.  We are now officiall…

    Kylie Batt

    12 May 10 at 3:03 pm

Leave a Reply